通达信丁丁选股,通达信条件选股怎么用

Q1:通达信选股公式怎么合并 输出不能超过一个 求老师帮忙

{信号同时满足}
{公式一 }
DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,5);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
A6:=MMS>MMM;
涨买入:=IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0);
{公式二}
丁丁1:=EMA(C,3);
丁丁2:=EMA(C,5);
丁丁3:=EMA(C,7);
丁丁4:=EMA(C,12);
丁丁5:=EMA(C,20);
SS:=CROSS(丁丁1,丁丁2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁1,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁1,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁4);
DD:=CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁2,丁丁5) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁3,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁2,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁5);
XG:涨买入 AND SS AND DD;
=======================
{满足其中一个信号}
{公式一 }
DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,5);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
A6:=MMS>MMM;
涨买入:=IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0);
{公式二}
丁丁1:=EMA(C,3);
丁丁2:=EMA(C,5);
丁丁3:=EMA(C,7);
丁丁4:=EMA(C,12);
丁丁5:=EMA(C,20);
SS:=CROSS(丁丁1,丁丁2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁1,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁1,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁4);
DD:=CROSS(丁丁2,丁丁3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁2,丁丁5) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁3,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(丁丁2,丁丁4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(丁丁1,丁丁5);
XG:涨买入 OR SS OR DD;

Q2:请老师根据副图做个通达信选股公式:条件是出现笑脸时预警

DRAWICON(CROSS(EMA(C,3),EMA(C,5)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA(C,3),EMA(C,12)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA(C,5),EMA(C,7)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA(C,3),EMA(C,7)) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(EMA(C,3),EMA(C,12)),L-0.04,5);

Q3:如何利用通达信软件中的选股器选股

通达信选股的步骤如下: 1.打开通达信股票软件; 2.选择“功能”菜单栏中的“选股器选项”; 3.选择“条件选股”; 4.在打开的对话框中的“条件选股公式”的下拉菜单中选择所需选股公式; 5.在“加入条件”文本框中输入自己的条件,可输入一个也可输入多个; 6.点击“改变范围”按钮选择范围; 7.点击“选股人版块”选择版块; 8.点击“执行选股”选择“条件股”; 9.点击“保存方案”完成。

Q4:通达信软件选股器怎样才能选出好股票

机器聪明还是人聪明